Baseten Web Application is down due to AWS outage. Inference is unaffected.

Incident Report for Baseten

Resolved

Upstream provider has recovered, and the Baseten web app is available.
Posted Oct 20, 2025 - 02:31 PDT

Investigating

Baseten web app is down due to the widespread AWS outage, but inference, new deploys, training jobs, and the model management APIs are unaffected.
Posted Oct 20, 2025 - 00:15 PDT
This incident affected: Web Application.